PHPエラーの解決方法とは?WordPressのPHPバージョンの変更方法

 
この記事を書いている人 - WRITER -
神楽大地(かぐらだいち)
詳しいプロフィールはこちら

WordPressを使っていると見慣れないエラーが発生することがあります。そういうときって『え?なにコレ?今までなかったのに・・・』と焦ってしまいますよね。

見慣れないエラーの一つがPHPエラーです。PHPエラーはそうそう起こるものではないのですが、2019年4月から一部のユーザーにPHPエラーが発生しているようです。

今回はその解決方法について紹介します。

 

PHPエラーの解決方法

このようなエラーが出ていると焦りますよね。実はこれは『PHPのバージョンが古いよ』という警告なのです。

 

この問題を解決するにはPHPのバージョンをアップする必要があるのです。今回はエックスサーバーを使って解説します。

 

エックスサーバーのホームページに行き、インフォパネルにログインします。

 

 

 

ログインしたらサーバー管理をクリックします。

 

 

サーバーパネルのところに『PHP Ver.切替』があるので、クリックします。

 

PHPエラー

 

現在のバージョンから新しいバージョンへ切り替えることができるようになります。

 

PHPエラー

 

ここで注意があります。以下WordPressの説明で以下のような一文があります。

 

(前略)使っているテーマやプラグインがどのバージョンで動作するかまでは分かりません。大部分は最新の PHP で動作しますし、人気があって信頼のおけるものはほぼ確実に動作しますが、保証はできません。

引用元:WordPress

 

つまり、一番新しいものバージョンにしたとしてもあなたが今使っている『テーマ』や『プラグイン』が確実に動くとは言い切れないということです。

 

実際、私もPHPを最新バージョンに切り替えたときに、エラーが起きてしまいました。なので、エラーが起きないバージョンはどれか、新しいものから試してみてください。

 

PHPはできるだけ新しいバージョンの方がいいと言われています。

  • Web サイトがより速くなります。PHP の最新バージョンは以前のバージョンよりも効率的に動作します。最新の対応バージョン (現在は7.3) にアップグレードすると、以前のバージョンに比べてパフォーマンスが最大で3倍〜4倍向上します。
  • Web サイトがより安全になります。PHP は WordPress と同様にコミュニティによってメンテナンスされています。PHP は非常に人気があるため、ハッカーの標的です。最新のバージョンには最新のセキュリティ機能が実装されていますが、以前のバージョンにはこうした機能が含まれていません。PHP のアップデートは WordPress サイトの安全性にとって非常に重要です。

さらに副次的な利点がいくつもあります。

  • 速い WordPress サイトは検索エンジンに高く評価されます。したがって検索ランクが上がります。
  • 速いサイトは訪問者の滞在時間が長くなります。訪問者は読み込みに長い時間がかかれば離脱しますが、パフォーマンスが良ければサイトはその分効果的になります。
  • 高いセキュリティを保つサイトはハッカーに対してより安全です。サイトがハッキングされれば対応コストがかかりますし、サイトの評判も下がります。

引用元:WordPress

なのでバージョンアップをする方がいいのです。

 

WordPressのサーバー環境を更新していない方は、できるだけ速やかPHPバージョンに切り替えましょう。

 

これで、PHPエラーが出なくなるはずです。それでは、最後までお付き合いいただきありがとうございました。

最初は焦るけど、意外と簡単に切替ができますね。

いちどーくん

バージョンアップした方がいいですよ。

ささめきさん

 

- Comments -

メールアドレスが公開されることはありません。

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください

Copyright© Kglass-神楽だいち公式サイト- , 2019 All Rights Reserved.